Not all audio streams are visible

DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Hi,
I have a Blu-Ray with 2 audio stream (Italian AC3 and English THD) but both DGDEMUX and DGINDEXNV find only the second stream
TFE_001.png
TFE_002.png
While BDINFO shows both audio streams
TFE_003.png
Tried with all options checked or unchecked but nothin changes.
Try also to demux by command line adding audio 1100 to the list of demuxed stream, I receive no error but nothing changes, the first audio stream is not demuxed.
Please let me know if you need more information.

Many thanks for your work and your help.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio stream are visible

Post by Rocky »

Thank you for the report, emilius256. Are you sure that's not the embedded AC3? When you demux the THD do you get an AC3? Some apps may list them separately, whereas DGDemuxGUI shows THD+embedded AC3 on one line. You've apparently downloaded this so I can't rule out that someone has done thdmerge of English THD and Italian AC3. I doubt you'd ever see that on a commercial bluray but who knows?

If that is not the issue, can you please use DGSplit to cut the first 50-100MB of 00005.m2ts and put it somewhere I can get it? If you need my FTP please let me know.
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Hi Rocky,
Thank you for the reply.
No, it is not the case, demuxing the THD stream I obtain the embedded AC3 in english Language.
I used eac3to and I was able to Demux the Italian track and it is the Italian Track.
You can download the file from here
https://we.tl/t-Wun9Pkb1Mw

May I ask you another thing ?
The THD demuxed track contains the delay information, while the embedded AC3 do not, The delay has been removed from the embedded AC3 or I need to still consider the same delay of the THD ?

Many thanks
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Use the THD delay for the embedded stream delay.

OK, the clip you gave is apparently too short and the AC3 audio begins relatively late in the complete stream. There are no 0x1100 packets in the clip, although 0x1100 is in the PAT/PMT as AC3. I don't approve an audio unless I see its packets. I may need to search deeper in the stream.

So it looks like I need the entire stream or at least a much bigger clip. How big is it? Maybe I can get by with a few GB. The clip needs to be big enough that you can see the 0x1100 stream when you do:

eac3to 00005_0.m2ts
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Hi Rocky,
The entire stream is 80GB, so I can't upload, but I created a bigger clip with the AC3 stream, and I think I found what may be the problem.
The Italian AC3 stream has a delay of 22067ms

Code: Select all

M2TS, 2 video tracks, 2 audio tracks, 3 subtitle tracks, 0:00:33, 12p
1: h265/HEVC, 2160p24 (16:9), 10 bits
2: h265/HEVC, 1080p24 (16:9), 10 bits - Dolby Vision Enhancement Layer
3: AC3, 5.1 channels, 640kbps, 48kHz, 22067ms
4: TrueHD/AC3, 5.1 channels, 48kHz, 111ms
   (embedded: AC3, 5.1 channels, 640kbps, 48kHz)
5: Subtitle (PGS)
6: Subtitle (PGS)
7: Subtitle (PGS)
So it will "start" 22 seconds after the beginning.
Never saw such a big delay.
Anyway this is the link for a 300MB clip of 33 seconds https://we.tl/t-bjN9ilaS4Y.
Many thanks for your efforts.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Yes, thank you emilius256, that confirms the theory. Rather than search deeper in the stream looking for the audio packets, which would add several seconds to the open time for all files, I will do this: After completing the search if there are any audio streams that were seen in the PAT/PMT but whose packets were not detected (due to the limited search depth), I go ahead and "approve" that audio stream as being the type stated in the PAT/PMT. BTW, this whole approval mechanism is a bit complicated and is intended to protect against header emulation and erroneous/missing PAT/PMT. I have the fix working fine on your stream and will release slipstreams later today. Thank you for your report and troubleshooting support.
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Thank to you Rocky for your help and your great work.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

You're welcome. I have slipstreamed the fix so if you'd like to re-download and test that would be great.
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Hi Rocky,

yes it is working, but not all the information of the track are recognized correctly:
TFE_004.png

Code: Select all

00002 PID 1100 0.0ch 48KHz 32Kbps ita DELAY 22067ms.ac3
While the audio is 5.1ch 640Kbps.

Anyway the audio extract and play correctly.
I will not loose more time on this, as you said, probably this track has been muxed and probably hasn't been muxed perfectly, this may lead to some errors in the recognition of the track.
I don't think there will be never any commercial disk authored like this one.

Thank you very much for your works, I really appreciate it.

Edit:
Ehm, sorry, I just realized that the information of the track are not there because no audio stream was found and for this reason can't be analyzed.
Thank you again.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Hmm, yes that's a deficiency of this hack. Maybe there's a better way that will search deep only when necessary. Let's see.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

OK, please re-download and test. The way it works now is it checks up to 576MB deep in the stream but breaks out early if all the candidate audio streams expected (from the PAT/PMT) have been detected. So it searches deep only when needed. This allows the stream properties to be properly detected for your stream.
User avatar
Sherman
Posts: 590
Joined: Mon Jan 06, 2020 10:19 pm

Not all audio streams are visible

Post by Sherman »

Hey Winkie, this emilius256 chap is pretty on-the-ball. What do you think?
User avatar
Curly
Posts: 728
Joined: Sun Mar 15, 2020 11:05 am

Not all audio streams are visible

Post by Curly »

Curly approval is in the final stages. Could be any minute now.
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Rocky wrote:
Tue Nov 29, 2022 8:50 am
OK, please re-download and test. The way it works now is it checks up to 576MB deep in the stream but breaks out early if all the candidate audio streams expected (from the PAT/PMT) have been detected. So it searches deep only when needed. This allows the stream properties to be properly detected for your stream.
Tested the new version, now the track is correctly recognized:

Code: Select all

10108 PID 1100 5.1ch 48KHz 640Kbps ita DELAY 22067ms.ac3
Great job, thank you.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Congratulations on your Moose Approval!
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

:bow:
Thank you all guys, I'm very glad and totally unexpected :oops:
DAE avatar
emilius256
Posts: 22
Joined: Mon Feb 06, 2012 2:41 pm

Not all audio streams are visible

Post by emilius256 »

Hi all,
I'm sorry but it seems I have again a problem with audio stream.
I have a disk with 18 audio stream, both DGDemux and DGIndexNV show only the first 2 audio stream:
TFE_001.png
While both BDInfo and Mediainfo shows the 18 stream:
TFE_002.png
It is not the same problem of the first case as all the audio streams are there since the beginning.
I don't know if the problem may be the large numbers of audio (18 stream) and subtitles (32 stream).
Here is a link to download a 100MB sample of the video https://we.tl/t-BQNd74kUmO

Thank you for your help.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

I'll need to get the disk. Opening the M2TS in DGIndexNV shows all the streams.

Can you make sure you have re-downloaded DGDemux 65 fresh from the website and tested that? If so, please give me a link to purchase the disk. Thank you.
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Worked with emilius256 via email to get CLPI and MPLS files. Recreated a minimal disk structure and duplicated the issue. I released slipstreams with a fix for DGDemux/DGDemuxGUI 65 and DGDecNV 247. Re-download these and update DGDemux.exe.
User avatar
hubblec4
Posts: 226
Joined: Tue May 02, 2023 6:03 pm

Not all audio streams are visible

Post by hubblec4 »

I also have a Blu-ray here in which 2 audio streams are not displayed.
eac3to, MKVToolNix and tsMuxeR handle this streams properly.

here a snip of an eac3to log

Code: Select all

-------------------- 00019.mpls --------------------
PID: 256/4113 ($ea), "VC-1", VC-1                                              
PID: 256/4352 ($86), DTS Master Audio                                          
PID: 256/4353 ($85), DTS Hi-Res                                                
PID: 256/4354 ($86), DTS Master Audio                                          
PID: 256/4355 ($81), "AC-3", AC3                                               
PID: 256/4356 ($81), "AC-3", AC3                                               
PID: 256/4357 ($81), "AC-3", AC3                                               
PID: 256/4358 ($81), "AC-3", AC3                                               
PID: 256/4608 ($90), Subtitle (PGS)                                            
PID: 256/4609 ($90), Subtitle (PGS)                                            
PID: 256/4610 ($90), Subtitle (PGS)                                            
PID: 256/4611 ($90), Subtitle (PGS)                                            
PID: 256/4612 ($90), Subtitle (PGS)                                            
PID: 256/4613 ($90), Subtitle (PGS)                                            
PID: 256/4614 ($90), Subtitle (PGS)                                            
PID: 256/4615 ($90), Subtitle (PGS)                                            
PID: 256/4616 ($90), Subtitle (PGS)                                            
PID: 256/4617 ($90), Subtitle (PGS)                                            
PID: 256/4618 ($90), Subtitle (PGS)                                            
PID: 256/4619 ($90), Subtitle (PGS)                                            
PID: 256/4620 ($90), Subtitle (PGS)                                            
PID: 256/4621 ($90), Subtitle (PGS)                                            
PID: 256/4622 ($90), Subtitle (PGS)                                            
PID: 256/4623 ($90), Subtitle (PGS)                                            
PID: 256/4624 ($90), Subtitle (PGS)                                            
PID: 256/4625 ($90), Subtitle (PGS)                                            
PID: 256/4626 ($90), Subtitle (PGS)                                            
PID: 256/6656 ($a2), DTS Express                                               
PID: 256/6657 ($a2), DTS Express                                               
PID: 256/6912 ($ea), "VC-1", VC-1   
Both DTS Express streams with PIDs 1A00 and 1A01 not seen by DGDemux.
I have already uploaded a chunk of this disc, it is Terminator 2.
https://www.rationalqm.us/board/downloa ... php?id=508
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Sorry, DTS Express is not supported at this time.

"I have already uploaded a chunk of this disc"

How did you do that? :scratch:
User avatar
hubblec4
Posts: 226
Joined: Tue May 02, 2023 6:03 pm

Not all audio streams are visible

Post by hubblec4 »

Rocky wrote:
Sun Jun 18, 2023 7:23 am
Sorry, DTS Express is not supported at this time.
Oh, why not? Is it to complicate to implement?
Rocky wrote:
Sun Jun 18, 2023 7:23 am
"I have already uploaded a chunk of this disc"

How did you do that? :scratch:
With my DiscShare tool. It is very easy to create such disc chunks.
https://forum.doom9.org/showthread.php?t=177187
User avatar
Rocky
Posts: 3665
Joined: Fri Sep 06, 2019 12:57 pm

Not all audio streams are visible

Post by Rocky »

Just never did it as nobody ever asked and the streams are generally useless stuff, not the main movie. But OK, I'll see how hard it is.

I meant how did you actually upload it to a 'download' directory that I never even knew we have. :o
User avatar
hubblec4
Posts: 226
Joined: Tue May 02, 2023 6:03 pm

Not all audio streams are visible

Post by hubblec4 »

Rocky wrote:
Sun Jun 18, 2023 12:43 pm
Just never did it as nobody ever asked and the streams are generally useless stuff, not the main movie. But OK, I'll see how hard it is.
This both DTS Express streams are commentary audios, when I remember correctly and belongs to the main movie.

Rocky wrote:
Sun Jun 18, 2023 12:43 pm
I meant how did you actually upload it to a 'download' directory that I never even knew we have. :o
There is a tab "Attachments" right of the "Options" tab under the Preview and Submit buttons.
User avatar
Curly
Posts: 728
Joined: Sun Mar 15, 2020 11:05 am

Not all audio streams are visible

Post by Curly »

Well I'll be. Just goes to show.
Post Reply