Little Monsters - subtitles out of sync

eac3to forked from madshi eac3to 3.36
Post Reply
DAE avatar
Peter
Posts: 25
Joined: Thu Aug 18, 2022 9:34 am

Little Monsters - subtitles out of sync

Post by Peter »

I think that I found a bug in the new eac3to. When demuxing the main-movie playlist of "Little Monsters" (USA, Lionsgate, Vestron Video Series disc), the subtitles are out of sync, but the video & audio are in sync. There is a single stream (so no seamless branching), but the playlist starts ~8 seconds into the stream (and skips the "ARTISAN Entertainment" animation present, at the beginning of the stream). The subtitles appear to be out of sync by this amount. If I demux the stream (rather than the playlist), the subtitles are in sync with the audio/video. The "ARTISAN Entertainment" animation is present in the demux (from playlist or stream).

If I demux the same playlist, using the old eac3to (v3.34), the subtitles are in sync with the audio/video.

Is the new eac3to maybe doing a "STRICT" demux of the playlist (accounting for the skipping of the "ARTISAN Entertainment" animation in the stream) for the subtitles, but not for the audio & video? Just guessing here, of course.
User avatar
Rocky
Posts: 3690
Joined: Fri Sep 06, 2019 12:57 pm

Little Monsters - subtitles out of sync

Post by Rocky »

Please provide a link to purchase the disk. Also, does it fail with DGDemux too?
DAE avatar
Peter
Posts: 25
Joined: Thu Aug 18, 2022 9:34 am

Little Monsters - subtitles out of sync

Post by Peter »

Rocky wrote:
Mon Apr 15, 2024 1:48 pm
Please provide a link to purchase the disk. Also, does it fail with DGDemux too?
Sorry, I’ve had connectivity issues all day.

Link for disc

It worked properly with DGDemux, though I did notice that the audio files generated by DGDemux had delays specified (-701ms for the main audio, and -168ms for the 2 commentaries). I didn’t see anything like that from eac3to (no delay processing mentioned in output), nor does MediaInfo report any delays for the audio in the playlist or stream, so DGDemux must be processing it differently.

I hope that helps. Thanks.
User avatar
Rocky
Posts: 3690
Joined: Fri Sep 06, 2019 12:57 pm

Little Monsters - subtitles out of sync

Post by Rocky »

Well, I asked for a link to buy the disk so I can reproduce the issue. I don't like to guess when my $$$ is at stake. So, if you want progress on the eac3to side, please give me a link to the exact disk.
DAE avatar
Peter
Posts: 25
Joined: Thu Aug 18, 2022 9:34 am

Little Monsters - subtitles out of sync

Post by Peter »

Rocky wrote:
Mon Apr 15, 2024 7:38 pm
Well, I asked for a link to buy the disk so I can reproduce the issue. I don't like to guess when my $$$ is at stake. So, if you want progress on the eac3to side, please give me a link to the exact disk.
Did you not see the link? It’s in BBcode in my reply. The link itself was not displaying initially in my post when pasted as text, so I updated it like 30 seconds later with BBcode. I’m not sure if you read my post before I updated it. I did post a link though, even at first. I’m posting via mobile also, which may have contributed to the initial link not working.

I did just notice that DGDemux did crop off the Artisan Entertainment animation at the beginning of the stream, so the result plays like the playlist would. Eac3to does not do that (historically or presently). Anyway, that explains the delays for audio tracks generated by DGDemux.
User avatar
Rocky
Posts: 3690
Joined: Fri Sep 06, 2019 12:57 pm

Little Monsters - subtitles out of sync

Post by Rocky »

Peter wrote:
Mon Apr 15, 2024 8:05 pm
The link itself was not displaying initially in my post when pasted as text, so I updated it like 30 seconds later with BBcode. I’m not sure if you read my post before I updated it.
Yep, that was it. Disk was ordered. I'll update further after it arrives.
DAE avatar
DelBoy83
Posts: 61
Joined: Wed Oct 04, 2023 2:04 am

Little Monsters - subtitles out of sync

Post by DelBoy83 »

Hi, i've got the same disc and it looks like when you play the mpls from the playlist folder no logo is present and all subs are correct. When the same mpls file is demuxed with the latest eac3to the logo is present causing the subs sync issue. I demuxed the m2ts stream and logo was again present and all was working fine.
DAE avatar
Peter
Posts: 25
Joined: Thu Aug 18, 2022 9:34 am

Little Monsters - subtitles out of sync

Post by Peter »

DelBoy83 wrote:
Thu May 30, 2024 5:42 am
Hi, i've got the same disc and it looks like when you play the mpls from the playlist folder no logo is present and all subs are correct. When the same mpls file is demuxed with the latest eac3to the logo is present causing the subs sync issue. I demuxed the m2ts stream and logo was again present and all was working fine.
Didn't my original post contain all of this information already? I'm not sure what you're trying to add here...
DAE avatar
DelBoy83
Posts: 61
Joined: Wed Oct 04, 2023 2:04 am

Little Monsters - subtitles out of sync

Post by DelBoy83 »

Yes, your original post did contain all relevant information. My post can be deleted. It's the first disk I've had that has this problem.
User avatar
Rocky
Posts: 3690
Joined: Fri Sep 06, 2019 12:57 pm

Little Monsters - subtitles out of sync

Post by Rocky »

All perspectives, explications, and confirmations are valuable. Thank you both.

I'll ask Curly to look into it.
DAE avatar
Peter
Posts: 25
Joined: Thu Aug 18, 2022 9:34 am

Little Monsters - subtitles out of sync

Post by Peter »

DelBoy83 wrote:
Sat Jun 08, 2024 7:24 am
Yes, your original post did contain all relevant information. My post can be deleted. It's the first disk I've had that has this problem.
OK, just making sure. This is the first disc that I've noticed this problem with, as well. Cheers.
Post Reply